avogadrolibs-0.7.2-r1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="Advanced molecule editor and visualizer 2 - libraries"
  6. HOMEPAGE="http://www.openchemistry.org/"
  7. SRC_URI="mirror://sourceforge/project/avogadro/avogadro2/${PV}/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="BSD GPL-2+"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="doc opengl qt4 static-plugins test vtk"
  12. REQUIRED_USE="qt4? ( opengl )"
  13. RDEPEND="
  14. >=sci-chemistry/molequeue-0.7
  15. sci-libs/chemkit
  16. sci-libs/hdf5:=
  17. opengl? (
  18. dev-qt/qtopengl:4
  19. media-libs/glew
  20. )
  21. qt4? (
  22. dev-qt/qtcore:4
  23. dev-qt/qtgui:4
  24. )
  25. vtk? ( sci-libs/vtk )
  26. "
  27. DEPEND="${DEPEND}
  28. test? ( dev-cpp/gtest )"
  29. PATCHES=( "${FILESDIR}"/${P}-6464.patch )
  30. src_configure() {
  31. local mycmakeargs=(
  32. -DUSE_PROTOCALL=OFF
  33. -DBUILD_GPL_PLUGINS=ON
  34. $(cmake-utils_use_build doc DOCUMENTATION)
  35. $(cmake-utils_use_use opengl OPENGL)
  36. $(cmake-utils_use_use qt4 QT)
  37. $(cmake-utils_use_build static-plugins STATIC_PLUGINS)
  38. $(cmake-utils_use_enable test TESTING)
  39. $(cmake-utils_use_use vtk VTK)
  40. )
  41. cmake-utils_src_configure
  42. }