avogadrolibs-0.9.0.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="Advanced molecule editor and visualizer 2 - libraries"
  6. HOMEPAGE="http://www.openchemistry.org/"
  7. SRC_URI="https://github.com/OpenChemistry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="BSD GPL-2+"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="doc hdf5 opengl qt5 static-plugins test vtk"
  12. REQUIRED_USE="qt5? ( opengl )"
  13. RDEPEND="
  14. >=sci-chemistry/molequeue-0.7
  15. sci-libs/chemkit
  16. hdf5? ( sci-libs/hdf5:= )
  17. opengl? (
  18. dev-qt/qtopengl:5
  19. media-libs/glew
  20. )
  21. qt5? (
  22. dev-qt/qtconcurrent:5
  23. dev-qt/qtcore:5
  24. dev-qt/qtgui:5
  25. dev-qt/qtnetwork:5
  26. dev-qt/qtwidgets:5
  27. )
  28. vtk? ( sci-libs/vtk )
  29. "
  30. DEPEND="${DEPEND}
  31. dev-cpp/eigen:3
  32. test? ( dev-cpp/gtest )"
  33. PATCHES=(
  34. "${FILESDIR}"/${PN}-0.7.2-6464.patch
  35. "${FILESDIR}/"${PN}-0.8.0-underlinking.patch
  36. )
  37. src_configure() {
  38. local mycmakeargs=(
  39. -DUSE_PROTOCALL=OFF
  40. -DBUILD_GPL_PLUGINS=ON
  41. -DUSE_MOLEQUEUE=ON
  42. -DUSE_HDF5=$(usex hdf5)
  43. -DBUILD_DOCUMENTATION=$(usex doc)
  44. -DUSE_OPENGL=$(usex opengl)
  45. -DUSE_QT=$(usex qt5)
  46. -DBUILD_STATIC_PLUGINS=$(usex static-plugins)
  47. -DENABLE_TESTING=$(usex test)
  48. -DUSE_VTK=$(usex vtk)
  49. )
  50. cmake-utils_src_configure
  51. }
  52. src_install() {
  53. cmake-utils_src_install
  54. # TODO: bundles jsoncpp
  55. rm "${ED%/}"/usr/lib64/libjsoncpp.a || die
  56. }