profnet-1.0.22.ebuild 660 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit fortran-2 toolchain-funcs
  5. DESCRIPTION="Neural network architecture for profacc"
  6. HOMEPAGE="https://rostlab.org/"
  7. SRC_URI="ftp://rostlab.org/profnet/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="GPL-3"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="sys-libs/libunwind"
  13. DEPEND="${RDEPEND}"
  14. src_prepare() {
  15. sed \
  16. -e '/$@/s:-o:$(LDFLAGS) -o:g' \
  17. -i src-phd/Makefile || die
  18. }
  19. src_compile() {
  20. emake \
  21. F77=$(tc-getF77) \
  22. FFLAGS="${FFLAGS}"
  23. }
  24. src_install() {
  25. emake \
  26. DESTDIR="${D}" \
  27. prefix="${EPREFIX}/usr" \
  28. install
  29. }