euler-1.61.0.ebuild 1014 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=1
  5. AUTOTOOLS_IN_SOURCE_BUILD=1
  6. inherit autotools-utils
  7. DESCRIPTION="Mathematical programming environment"
  8. HOMEPAGE="http://euler.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/euler/${P}.tgz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 ppc -sparc x86 ~amd64-linux ~x86-linux"
  13. IUSE=""
  14. DEPEND="x11-libs/gtk+:2
  15. virtual/pkgconfig"
  16. RDEPEND="x11-libs/gtk+:2
  17. x11-misc/xdg-utils"
  18. PATCHES=(
  19. "${FILESDIR}"/configure-gentoo.patch
  20. "${FILESDIR}"/command-gcc4-gentoo.patch
  21. "${FILESDIR}"/${PN}-glibc-2.4-gentoo.patch
  22. "${FILESDIR}"/${PN}-xdg.patch
  23. "${FILESDIR}"/${PN}-fortify.patch
  24. )
  25. src_prepare() {
  26. # gentoo specific stuff
  27. sed -i -e '/COPYING/d' -e '/INSTALL/d' Makefile.am || die
  28. sed -i \
  29. -e "s:doc/euler:doc/${PF}:g" \
  30. Makefile.am docs/Makefile.am \
  31. docs/*/Makefile.am docs/*/images/Makefile.am src/main.c \
  32. || die "sed for docs failed"
  33. autotools-utils_src_prepare
  34. }