jags-3.4.0.ebuild 977 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils toolchain-funcs
  5. MYP="JAGS-${PV}"
  6. DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
  7. HOMEPAGE="http://mcmc-jags.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/3.x/Source/${MYP}.tar.gz"
  9. LICENSE="GPL-2"
  10. IUSE="doc"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
  13. RDEPEND="
  14. virtual/blas
  15. virtual/lapack"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig
  18. doc? (
  19. virtual/latex-base
  20. dev-texlive/texlive-latexextra
  21. )"
  22. S="${WORKDIR}/${MYP}"
  23. src_configure() {
  24. local myeconfargs=(
  25. --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
  26. --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
  27. )
  28. autotools-utils_src_configure
  29. }
  30. src_compile() {
  31. autotools-utils_src_compile all $(use doc && echo docs)
  32. }
  33. src_install() {
  34. autotools-utils_src_install
  35. use doc && dodoc "${BUILD_DIR}"/doc/manual/*.pdf
  36. }