rkward-0.6.5.ebuild 755 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. KDE_DOC_DIRS="doc"
  5. KDE_HANDBOOK="optional"
  6. WEBKIT_REQUIRED="always"
  7. inherit kde4-base
  8. DESCRIPTION="IDE for the R-project"
  9. HOMEPAGE="https://rkward.kde.org/"
  10. SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="4"
  13. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  14. IUSE="debug"
  15. DEPEND="
  16. $(add_kdeapps_dep katepart)
  17. dev-lang/R
  18. x11-libs/libX11
  19. "
  20. RDEPEND="${DEPEND}"
  21. src_configure() {
  22. # to have it compatible with R which had a bad R_HOME
  23. unset R_HOME
  24. kde4-base_src_configure
  25. }
  26. src_install() {
  27. kde4-base_src_install
  28. # avoid file collision with kate
  29. rm "${ED}"/usr/share/apps/katepart/syntax/r.xml || die
  30. }