topcom-0.17.7.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic
  5. DESCRIPTION="Computing Triangulations Of Point Configurations and Oriented Matroids"
  6. HOMEPAGE="http://www.rambau.wm.uni-bayreuth.de/TOPCOM/"
  7. SRC_URI="
  8. http://www.rambau.wm.uni-bayreuth.de/Software/TOPCOM-${PV}.tar.gz
  9. doc? ( http://www.rambau.wm.uni-bayreuth.de/TOPCOM/TOPCOM-manual.html )"
  10. KEYWORDS="~amd64 ~x86"
  11. SLOT="0"
  12. LICENSE="GPL-2"
  13. IUSE="doc examples static-libs"
  14. DEPEND="
  15. dev-libs/gmp:0
  16. >=sci-libs/cddlib-094f"
  17. RDEPEND="${DEPEND}"
  18. PATCHES=(
  19. "${FILESDIR}"/${P}-buildsystem.patch
  20. )
  21. src_prepare () {
  22. # ... and link in tree versions:
  23. append-libs -lgmp -lgmpxx -lcddgmp
  24. find external -delete || die
  25. default
  26. }
  27. src_install () {
  28. default
  29. use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*a
  30. use examples && dodoc -r "${S}"/examples
  31. docinto /usr/share/doc/${PF}/html
  32. use doc && dodoc "${DISTDIR}"/TOPCOM-manual.html
  33. mv "${ED}"/usr/bin/cube "${ED}"/usr/bin/topcom_cube || die
  34. }
  35. pkg_postinst() {
  36. elog "Due to a file collision with media-libs/lib3ds the helper"
  37. elog "'cube' has been installed as topcom_cube (see bug #547030)."
  38. }