vitables-2.1-r1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1
  6. MY_P=ViTables-${PV}
  7. DESCRIPTION="A graphical tool for browsing / editing files in both PyTables and HDF5 formats"
  8. HOMEPAGE="http://vitables.org/"
  9. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  13. IUSE="doc examples"
  14. RDEPEND="
  15. dev-python/pytables[${PYTHON_USEDEP}]
  16. dev-python/PyQt4[X,${PYTHON_USEDEP}]" # FIXME: check if any other useflags are needed
  17. DEPEND="${RDEPEND}
  18. doc? ( dev-python/sphinx )"
  19. S=${WORKDIR}/${MY_P}
  20. PATCHES=( "${FILESDIR}"/${P}-no-docs.patch )
  21. python_compile_all() {
  22. # fixme: multiple python (anyone cares?)
  23. use doc && esetup.py build_sphinx
  24. }
  25. python_install_all() {
  26. dodir /usr/share/icons/hicolor/scalable/apps
  27. dodir /usr/share/applications
  28. if use examples; then
  29. docompress -x /usr/share/doc/${PF}/examples
  30. DOCS+=( examples )
  31. fi
  32. if use doc; then
  33. HTML_DOCS+=( "${BUILD_DIR}"/sphinx/html/. )
  34. DOCS+=( "${BUILD_DIR}"/sphinx/latex/*.pdf )
  35. fi
  36. distutils-r1_python_install_all
  37. }