12345678910111213141516171819202122232425262728293031323334353637 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=6
- inherit gnome2
- DESCRIPTION="Disk usage browser for GNOME"
- HOMEPAGE="https://wiki.gnome.org/Apps/Baobab"
- LICENSE="GPL-2+ FDL-1.1+"
- SLOT="0"
- IUSE=""
- KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
- COMMON_DEPEND="
- >=dev-libs/glib-2.40:2[dbus]
- >=x11-libs/gtk+-3.19.1:3
- "
- RDEPEND="${COMMON_DEPEND}
- gnome-base/gsettings-desktop-schemas
- x11-themes/adwaita-icon-theme
- !<gnome-extra/gnome-utils-3.4
- "
- # ${PN} was part of gnome-utils before 3.4
- DEPEND="${COMMON_DEPEND}
- app-text/yelp-tools
- dev-libs/appstream-glib
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
- "
- src_configure() {
- gnome2_src_configure \
- VALAC=$(type -P true) \
- VAPIGEN=$(type -P true)
- }
|