baobab-3.22.1.ebuild 826 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="Disk usage browser for GNOME"
  6. HOMEPAGE="https://wiki.gnome.org/Apps/Baobab"
  7. LICENSE="GPL-2+ FDL-1.1+"
  8. SLOT="0"
  9. IUSE=""
  10. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. COMMON_DEPEND="
  12. >=dev-libs/glib-2.40:2[dbus]
  13. >=x11-libs/gtk+-3.19.1:3
  14. "
  15. RDEPEND="${COMMON_DEPEND}
  16. gnome-base/gsettings-desktop-schemas
  17. x11-themes/adwaita-icon-theme
  18. !<gnome-extra/gnome-utils-3.4
  19. "
  20. # ${PN} was part of gnome-utils before 3.4
  21. DEPEND="${COMMON_DEPEND}
  22. app-text/yelp-tools
  23. dev-libs/appstream-glib
  24. >=sys-devel/gettext-0.19.8
  25. virtual/pkgconfig
  26. "
  27. src_configure() {
  28. gnome2_src_configure \
  29. VALAC=$(type -P true) \
  30. VAPIGEN=$(type -P true)
  31. }