collectl-4.0.5.ebuild 899 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="light-weight performance monitoring tool capable of reporting interactively and logging to disk"
  5. HOMEPAGE="http://collectl.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/collectl/${P}.src.tar.gz"
  7. LICENSE="GPL-2 Artistic"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
  10. IUSE=""
  11. RDEPEND=">=dev-lang/perl-5.8.8
  12. virtual/perl-Time-HiRes
  13. >=dev-perl/Archive-Zip-1.20
  14. sys-apps/ethtool
  15. sys-apps/pciutils"
  16. src_prepare() {
  17. sed -i INSTALL -e "/^DOCDIR/s:doc/collectl:doc/${PF}:" || die
  18. }
  19. src_install() {
  20. DESTDIR="${D}" bash -ex ./INSTALL || die
  21. rm "${D}"/etc/init.d/* || die
  22. newinitd "${FILESDIR}"/collectl.initd-2 collectl
  23. rm "${D}"/usr/share/${PN}/UNINSTALL || die
  24. cd "${D}"/usr/share/doc/${PF} || die
  25. dohtml *
  26. rm ARTISTIC GPL COPYING *.html *.jpg *.css || die
  27. }