cracklib-words-2.9.6.ebuild 724 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. DESCRIPTION="large set of crack/cracklib dictionaries"
  5. HOMEPAGE="https://github.com/cracklib/cracklib/"
  6. SRC_URI="https://github.com/cracklib/cracklib/releases/download/${P/-words}/${P}.gz"
  7. LICENSE="public-domain"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
  10. IUSE=""
  11. S=${WORKDIR}
  12. src_install() {
  13. insinto /usr/share/dict
  14. newins ${P} ${PN}
  15. }
  16. pkg_postinst() {
  17. if [ "${ROOT}" = "/" ] && create-cracklib-dict -h >&/dev/null ; then
  18. ebegin "Regenerating cracklib dictionary"
  19. create-cracklib-dict /usr/share/dict/* >/dev/null
  20. eend $?
  21. fi
  22. }