debianutils-4.8.1.ebuild 967 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic
  5. DESCRIPTION="A selection of tools from Debian"
  6. HOMEPAGE="http://packages.qa.debian.org/d/debianutils.html"
  7. SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.xz"
  8. LICENSE="BSD GPL-2 SMAIL"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
  11. IUSE="kernel_linux static"
  12. src_prepare() {
  13. epatch "${FILESDIR}"/${PN}-3.4.2-no-bs-namespace.patch
  14. }
  15. src_configure() {
  16. use static && append-ldflags -static
  17. default
  18. }
  19. src_install() {
  20. into /
  21. dobin tempfile run-parts
  22. if use kernel_linux ; then
  23. dosbin installkernel
  24. fi
  25. into /usr
  26. dosbin savelog
  27. doman tempfile.1 run-parts.8 savelog.8
  28. use kernel_linux && doman installkernel.8
  29. cd debian || die
  30. dodoc changelog control
  31. keepdir /etc/kernel/postinst.d
  32. }