fakeroot-1.19.ebuild 835 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils
  5. DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
  6. HOMEPAGE="http://packages.qa.debian.org/f/fakeroot.html"
  7. SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~arm hppa ppc sparc x86 ~amd64-linux ~x86-linux"
  11. IUSE="acl static-libs test"
  12. DEPEND="acl? ( sys-apps/acl )
  13. test? ( app-arch/sharutils )
  14. sys-libs/libcap"
  15. DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${PN}-1.19-no-acl_h.patch
  18. }
  19. src_configure() {
  20. export ac_cv_header_sys_acl_h=$(usex acl)
  21. econf \
  22. $(use_enable static-libs static)
  23. }
  24. src_install() {
  25. default
  26. prune_libtool_files
  27. }