ibm-powerpc-utils-1.1.0.ebuild 872 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. MY_P="powerpc-utils-${PV}"
  5. DESCRIPTION="This package provides utilities for the maintainance
  6. of the IBM and Apple powerpc platforms."
  7. SRC_URI="http://powerpc-utils.ozlabs.org/releases/${MY_P}.tar.gz"
  8. HOMEPAGE="http://powerpc-utils.ozlabs.org/"
  9. S="${WORKDIR}/${MY_P}"
  10. SLOT="0"
  11. LICENSE="IBM"
  12. KEYWORDS="ppc ppc64"
  13. IUSE=""
  14. DEPEND=">=sys-libs/librtas-1.3.1
  15. sys-devel/bc"
  16. RDEPEND="!sys-apps/ppc64-utils"
  17. src_unpack() {
  18. unpack ${A}
  19. epatch "${FILESDIR}"/ibm-powerpc-utils-1.1.0-remove-doc.patch
  20. }
  21. src_install() {
  22. make DESTDIR="${D}" install || die "Something went wrong"
  23. # dodoc README COPYRIGHT
  24. }
  25. pkg_postinst() {
  26. einfo "If you are running IBM hardware, consider emerging "
  27. einfo "sys-apps/ibm-powerpc-utils-papr for additional functions. "
  28. }