lcdsplash-0.3.ebuild 646 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit multilib
  4. DESCRIPTION="splash Gentoo boot information on LCD's"
  5. HOMEPAGE="https://www.gentoo.org/"
  6. SRC_URI="mirror://gentoo/${P}.tar.bz2
  7. https://dev.gentoo.org/~vapier/dist/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="hppa ~mips x86"
  11. IUSE=""
  12. DEPEND="mips? ( sys-apps/lcdutils )"
  13. S=${WORKDIR}/${PN}
  14. src_install() {
  15. insinto /sbin
  16. doins splash-functions.sh || die "splash"
  17. insinto /$(get_libdir)/rcscripts/lcdsplash
  18. doins -r modules/* || die "modules"
  19. insinto /etc
  20. doins lcdsplash.conf || die "conf"
  21. dodoc README
  22. }