lmctfy-0.2.0.ebuild 782 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Linux application container management from Google"
  6. HOMEPAGE="https://github.com/google/lmctfy"
  7. SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="Apache-2.0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="test"
  12. DEPEND="
  13. dev-libs/protobuf
  14. dev-cpp/gflags
  15. dev-libs/re2
  16. "
  17. RDEPEND="${DEPEND}"
  18. src_compile() {
  19. # test deps take too long to compile
  20. use test && emake || emake lmctfy liblmctfy.a
  21. }
  22. src_install() {
  23. # silly upstream!
  24. mkdir -p "${D}/usr/bin"
  25. cp "${S}/bin/lmctfy/cli/lmctfy" "${D}/usr/bin/" || die "Failed to copy cli binary"
  26. dolib.a "${S}/bin/liblmctfy.a" || die "Failed to copy library"
  27. }