man2html-1.6g.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs
  5. MY_P="man-${PV}"
  6. DESCRIPTION="Standard commands to read man pages"
  7. HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
  8. SRC_URI="http://primates.ximian.com/~flucifredi/man/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="!sys-apps/man"
  14. S="${WORKDIR}/${MY_P}"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/man-1.6f-man2html-compression-2.patch
  17. epatch "${FILESDIR}"/man-1.6-cross-compile.patch
  18. epatch "${FILESDIR}"/man-1.6g-compress.patch #205147
  19. }
  20. echoit() { echo "$@" ; "$@" ; }
  21. src_configure() {
  22. tc-export CC BUILD_CC
  23. # Just a stub to disable configure check. man2html doesn't use it.
  24. export COMPRESS=true
  25. echoit \
  26. ./configure \
  27. -confdir=/etc \
  28. +sgid +fhs \
  29. +lang none \
  30. || die "configure failed"
  31. }
  32. src_compile() {
  33. emake {src,man2html}/Makefile
  34. emake -C src version.h
  35. emake -C man2html
  36. }
  37. src_install() {
  38. # A little faster to run this by hand than `emake install`.
  39. cd man2html
  40. dobin man2html
  41. doman man2html.1
  42. dodoc README TODO
  43. }