mount-gtk-1.4.2.ebuild 858 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils flag-o-matic
  5. DESCRIPTION="GTK+ based UDisks2 frontend"
  6. HOMEPAGE="http://mount-gtk.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND=">=dev-libs/glib-2.28
  13. sys-fs/udisks:2
  14. x11-libs/c++-gtk-utils:0
  15. x11-libs/libX11
  16. x11-libs/libnotify:="
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig"
  19. DOCS=( AUTHORS BUGS ChangeLog )
  20. src_prepare() {
  21. epatch "${FILESDIR}"/${P}-c++11.patch
  22. sed -i -e 's:AC_CONFIG_HEADER:&S:' configure.ac || die
  23. eautoreconf
  24. }
  25. src_configure() {
  26. # acinclude.m4 is broken and environment flags override these:
  27. append-cxxflags -fexceptions -frtti -fsigned-char -fno-check-new -pthread
  28. econf --docdir=/usr/share/doc/${PF}
  29. }