mtree-1.0.1.ebuild 572 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. DESCRIPTION="Directory hierarchy mapping tool from FreeBSD"
  6. HOMEPAGE="https://github.com/archiecobbs/mtree-port"
  7. SRC_URI="https://mtree-port.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. src_prepare() {
  12. # don't install unneeded docs
  13. sed -i '/doc_DATA=/d' Makefile.am || die
  14. eautoreconf
  15. }
  16. src_install() {
  17. default
  18. # avoid conflict with app-arch/libarchive
  19. rm "${ED}usr/share/man/man5/mtree.5"
  20. }