readahead-list-1.20060421.1016-r2.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Preloads files into the page cache to accelerate program loading"
  5. HOMEPAGE="http://www.orbis-terrarum.net"
  6. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. IUSE="doc"
  11. RDEPEND=""
  12. DEPEND="${RDEPEND}
  13. virtual/os-headers
  14. "
  15. PATCHES=(
  16. "${FILESDIR}/${P}-gcc-4.3.patch"
  17. "${FILESDIR}/${P}-gcc6.patch"
  18. )
  19. src_configure() {
  20. econf --sbindir=/sbin
  21. }
  22. src_install() {
  23. default
  24. # init scripts
  25. #cd "${S}/contrib/init/gentoo/"
  26. newinitd "${FILESDIR}"/init.d-readahead-list readahead-list
  27. newinitd "${FILESDIR}"/init.d-readahead-list-early readahead-list-early
  28. newconfd "${FILESDIR}"/conf.d-readahead-list readahead-list
  29. # default config
  30. insinto /etc/readahead-list
  31. cd "${S}/contrib/data"
  32. newins readahead.runlevel-default.list runlevel-default
  33. newins readahead.runlevel-boot.list runlevel-boot
  34. newins readahead._sbin_rc.list exec_sbin_rc
  35. # docs
  36. cd "${S}"
  37. if use doc; then
  38. docinto scripts
  39. dodoc contrib/scripts/*
  40. fi
  41. # clean up a bit
  42. find "${D}/usr/share/doc/${PF}/" -type f -name 'Makefile*' -exec rm -f \{\} \;
  43. }
  44. pkg_postinst() {
  45. einfo "You should add readahead-list to your runlevels:"
  46. einfo " rc-update add readahead-list-early boot"
  47. einfo " rc-update add readahead-list boot"
  48. einfo "Also consider customizing the lists in /etc/readahead-list"
  49. einfo "for maximum performance gain."
  50. }