s6-2.2.4.3.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="skarnet.org's small and secure supervision software suite"
  5. HOMEPAGE="http://www.skarnet.org/software/s6/"
  6. SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
  7. LICENSE="ISC"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE="static static-libs"
  11. DEPEND=">=sys-devel/make-4.0
  12. static? (
  13. >=dev-lang/execline-2.1.4.5[static-libs]
  14. >=dev-libs/skalibs-2.3.9.0[static-libs]
  15. )
  16. !static? (
  17. >=dev-lang/execline-2.1.4.5
  18. >=dev-libs/skalibs-2.3.9.0
  19. )
  20. "
  21. RDEPEND="
  22. !static? (
  23. >=dev-lang/execline-2.1.4.5
  24. >=dev-libs/skalibs-2.3.9.0
  25. )
  26. "
  27. DOCS="AUTHORS examples README*"
  28. HTML_DOCS="doc/*"
  29. src_prepare()
  30. {
  31. # Remove QA warning about LDFLAGS addition
  32. sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
  33. eapply_user
  34. }
  35. src_configure()
  36. {
  37. econf \
  38. $(use_enable !static shared) \
  39. $(use_enable static-libs static) \
  40. $(use_enable static allstatic) \
  41. --bindir=/bin \
  42. --sbindir=/sbin \
  43. --dynlibdir=/$(get_libdir) \
  44. --libdir=/usr/$(get_libdir)/${PN} \
  45. --datadir=/etc \
  46. --sysdepdir=/usr/$(get_libdir)/${PN} \
  47. --with-dynlib=/$(get_libdir) \
  48. --with-sysdeps=/usr/$(get_libdir)/skalibs
  49. }