tuxonice-userui-1.1-r2.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="User Interface for TuxOnIce"
  6. HOMEPAGE="http://tuxonice.nigelcunningham.com.au/ https://github.com/NigelCunningham/Tuxonice-Userui"
  7. SRC_URI="http://tuxonice.net/files/${P}.tar.gz -> ${P}.tar
  8. mirror://debian/pool/main/t/${PN}/${PN}_${PV}-2~exp1.debian.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="fbsplash"
  13. DEPEND="fbsplash? (
  14. media-libs/freetype:2=
  15. media-libs/libmng:0=
  16. media-libs/libpng:0=
  17. virtual/jpeg:0=
  18. )"
  19. RDEPEND="${DEPEND}"
  20. S="${WORKDIR}/${PN}"
  21. src_prepare() {
  22. local d=${WORKDIR}/debian/patches
  23. EPATCH_SOURCE=${d} epatch $(<"${d}"/series)
  24. epatch "${FILESDIR}"/${P}-freetype-2.5.patch
  25. sed -i -e 's/make/$(MAKE)/' Makefile || die
  26. sed -i -e 's/ -O3//' Makefile fbsplash/Makefile usplash/Makefile || die
  27. }
  28. src_compile() {
  29. # Package contain binaries
  30. emake clean
  31. use fbsplash && export USE_FBSPLASH=1
  32. emake CC="$(tc-getCC)" tuxoniceui
  33. }
  34. src_install() {
  35. into /
  36. dosbin tuxoniceui
  37. dodoc AUTHORS ChangeLog KERNEL_API README TODO USERUI_API
  38. }
  39. pkg_postinst() {
  40. if use fbsplash; then
  41. einfo
  42. elog "You must create a symlink from /etc/splash/tuxonice"
  43. elog "to the theme you want tuxonice to use, e.g.:"
  44. elog
  45. elog " # ln -sfn /etc/splash/emergence /etc/splash/tuxonice"
  46. fi
  47. einfo
  48. einfo "Please see /usr/share/doc/${PF}/README.* for further"
  49. einfo "instructions."
  50. einfo
  51. }