ucspi-unix-0.36-r4.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils toolchain-funcs multilib
  5. DESCRIPTION="A ucspi implementation for unix sockets"
  6. HOMEPAGE="http://untroubled.org/ucspi-unix/"
  7. SRC_URI="http://untroubled.org/ucspi-unix/archive/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~sparc ~x86"
  11. IUSE=""
  12. # We statically link bglibs.
  13. DEPEND=">=dev-libs/bglibs-1.106"
  14. # Block other unixcat installers. #480546
  15. RDEPEND="!net-analyzer/mk-livestatus"
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${PN}-gentoo-head.patch
  18. epatch "${FILESDIR}"/${P}-include-sys_socket.h.patch
  19. epatch "${FILESDIR}"/${P}-fix-parallel-build.patch
  20. }
  21. src_configure() {
  22. local has_peercred
  23. use kernel_linux && has_peercred="-DHASPEERCRED=1"
  24. echo "$(tc-getCC) ${CPPFLAGS} ${CFLAGS} -I${SYSROOT}/usr/include/bglibs ${has_peercred} -D_GNU_SOURCE" > conf-cc
  25. echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS} -L${SYSROOT}/usr/$(get_libdir)/bglibs" > conf-ld
  26. }
  27. src_install() {
  28. dobin unixserver unixclient unixcat
  29. doman unixserver.1 unixclient.1
  30. dodoc ANNOUNCEMENT NEWS PROTOCOL README TODO
  31. }