usbmon-6-r1.ebuild 631 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs eutils
  5. DESCRIPTION="Userland for USB monitoring framework"
  6. HOMEPAGE="https://people.redhat.com/zaitcev/linux/"
  7. SRC_URI="${HOMEPAGE}/${P}.tar.gz"
  8. LICENSE="GPL-2" # GPL-2 only
  9. SLOT="0"
  10. KEYWORDS="~x86 ~ppc ~amd64"
  11. IUSE=""
  12. DEPEND="!=sys-apps/usbutils-0.72-r2"
  13. src_prepare() {
  14. epatch "${FILESDIR}"/${P}-sysmacros.patch #580360
  15. sed \
  16. -e '/CFLAGS =/s, = , \+= ,g' \
  17. -e 's:-O2::g' \
  18. -i "${S}"/Makefile || die
  19. tc-export CC
  20. }
  21. src_install() {
  22. dosbin ${PN}
  23. doman ${PN}.8
  24. dodoc README
  25. }