blocks-0.1.4_pre131210-r1.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python3_4 )
  5. inherit distutils-r1
  6. DESCRIPTION="Conversion tools for block devices"
  7. HOMEPAGE="https://github.com/g2p/blocks"
  8. SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
  9. SLOT="0"
  10. LICENSE="GPL-3+"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. IUSE="+minimal"
  13. DEPEND="
  14. dev-python/maintboot
  15. >=dev-python/pyparted-3.10[${PYTHON_USEDEP}]
  16. >=dev-python/python-augeas-0.5.0[${PYTHON_USEDEP}]
  17. "
  18. RDEPEND="${DEPEND}
  19. >=sys-block/parted-2.3
  20. !minimal? (
  21. sys-fs/btrfs-progs
  22. sys-fs/lvm2
  23. sys-fs/bcache-tools
  24. sys-fs/nilfs-utils
  25. sys-fs/cryptsetup
  26. sys-fs/reiserfsprogs
  27. sys-fs/xfsprogs
  28. sys-fs/e2fsprogs
  29. )
  30. "
  31. # NEVER, EVER run filesystem tests during build
  32. RESTRICT="test"
  33. python_test() {
  34. cd tests || die
  35. emake
  36. }
  37. pkg_postinst() {
  38. if use minimal; then
  39. einfo "For filesystem support you need to install:"
  40. echo
  41. einfo "btrfs: sys-fs/btrfs-progs"
  42. einfo "LVM: sys-fs/lvm2"
  43. einfo "bcache: sys-fs/bcache-tools"
  44. einfo "NILFS: sys-fs/nilfs-utils"
  45. einfo "crypted FS: sys-fs/cryptsetup"
  46. einfo "reiser: sys-fs/reiserfsprogs"
  47. einfo "XFS: sys-fs/xfsprogs"
  48. einfo "EXT2/3/4: sys-fs/e2fsprogs"
  49. echo
  50. fi
  51. }