gpart-0.1h-r2.ebuild 943 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="Partition table rescue/guessing tool"
  5. HOMEPAGE="http://www.stud.uni-hannover.de/user/76201/gpart/"
  6. SRC_URI="http://www.stud.uni-hannover.de/user/76201/gpart/${P}.tar.gz
  7. ftp://ftp.namesys.com/pub/misc-patches/gpart-0.1h-reiserfs-3.6.patch.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa x86"
  11. IUSE=""
  12. RDEPEND=""
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/${P}-errno.patch
  17. epatch "${FILESDIR}"/${P}-vfat.patch
  18. epatch "${FILESDIR}"/${P}-ntfs.patch
  19. epatch "${WORKDIR}"/gpart-0.1h-reiserfs-3.6.patch
  20. epatch "${FILESDIR}"/${P}-l64seek.patch
  21. epatch "${FILESDIR}"/${P}-openmode.patch
  22. sed -i -e "/^CFLAGS/s: -O2 : ${CFLAGS} :" make.defs
  23. sed -i -e "/^LDFLAGS/s:=:=${LDFLAGS} :" make.defs
  24. }
  25. src_install() {
  26. dobin src/gpart || die
  27. doman man/gpart.8
  28. dodoc README Changes INSTALL LSM
  29. }