lsiutil-1.62-r2.ebuild 911 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. DESCRIPTION="LSI Logic Fusion MPT Command Line Interface management tool"
  5. HOMEPAGE="http://www.avagotech.com/"
  6. SRC_URI="http://docs.avagotech.com/docs-and-downloads/legacy-host-bus-adapters/legacy-host-bus-adapters-common-files/LSIUtil_${PV/./-}.zip"
  7. LICENSE="LSI"
  8. SLOT="0"
  9. # This package can never enter stable, it can't be mirrored and upstream
  10. # can remove the distfiles from their mirror anytime.
  11. KEYWORDS="~amd64 ~ia64 ~x86"
  12. IUSE=""
  13. RESTRICT="mirror bindist"
  14. RDEPEND=""
  15. DEPEND="app-arch/unzip"
  16. QA_PRESTRIPPED="/opt/bin/lsiutil"
  17. S="${WORKDIR}"
  18. src_install() {
  19. exeinto /opt/bin
  20. if use x86; then
  21. doexe Linux/lsiutil || die
  22. elif use amd64; then
  23. newexe Linux/lsiutil.x86_64 lsiutil || die
  24. elif use ia64; then
  25. newexe Linux/lsiutil.ia64 lsiutil || die
  26. fi
  27. dodoc changes.txt
  28. }