noflushd-2.7.5.ebuild 764 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. DESCRIPTION="A daemon to spin down your disks and force accesses to be cached"
  4. HOMEPAGE="http://noflushd.sourceforge.net/"
  5. SRC_URI="mirror://sourceforge/noflushd/${PN}_${PV}.orig.tar.gz"
  6. LICENSE="GPL-2"
  7. SLOT="0"
  8. KEYWORDS="~amd64 ~ppc ~x86"
  9. IUSE=""
  10. src_compile() {
  11. econf \
  12. --with-docdir=/usr/share/doc/${PF} \
  13. --with-initdir=/etc/init.d
  14. emake || die
  15. }
  16. src_install() {
  17. emake install DESTDIR="${D}" || die
  18. dodoc NEWS
  19. prepalldocs
  20. newinitd "${FILESDIR}"/noflushd.rc6 noflushd
  21. newconfd "${FILESDIR}"/noflushd.confd noflushd
  22. }
  23. pkg_postinst() {
  24. ewarn "noflushd works with IDE devices only."
  25. ewarn "It has possible problems with reiserfs, too."
  26. }