sas2ircu-19.ebuild 3.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit mount-boot
  5. DESCRIPTION="LSI MPT-SAS2 controller management tool"
  6. HOMEPAGE="http://www.lsi.com/support/Pages/download-results.aspx?component=Storage+Component&productfamily=Host+Bus+Adapters&productcode=0&assettype=Miscellaneous&productname=&keyword=SAS2IRCU"
  7. LICENSE="LSI"
  8. SLOT="0"
  9. KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~ppc64 ~amd64-fbsd ~sparc-solaris ~x64-solaris ~x86-solaris"
  10. IUSE="efi doc"
  11. RESTRICT="strip fetch mirror"
  12. DEPEND=""
  13. RDEPEND=""
  14. QA_PREBUILT="opt/lsi/sas2ircu boot/efi/sas2ircu.efi"
  15. MY_PN=SAS2IRCU
  16. MY_P="${MY_PN}_P${PV}"
  17. DISTFILE_BIN=${MY_P}.zip
  18. DISTFILE_DOC=SAS2IRCU_User_Guide.pdf
  19. DOC_PV=12
  20. SRC_URI="
  21. http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_6G_P${PV}/$DISTFILE_BIN
  22. doc? ( http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_6G_P${DOC_PV}/SAS2IRCU_User_Guide.pdf )
  23. "
  24. LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
  25. S="${WORKDIR}/${MY_P}"
  26. pkg_nofetch() {
  27. elog "LSI has a mandatory click-through license on thier binaries."
  28. elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the Miscellaneous section."
  29. elog "After downloading, move ${MY_P} into $DISTDIR"
  30. if use doc; then
  31. elog "Please also download 'SAS-2 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
  32. elog "and also place it into $DISTDIR"
  33. fi
  34. }
  35. supportedcards() {
  36. elog "This binary supports should support ALL cards, including, but not"
  37. elog "limited to the following series:"
  38. elog ""
  39. elog "LSI SAS 2004"
  40. elog "LSI SAS 2008"
  41. elog "LSI SAS 2108"
  42. elog "LSI SAS 2208"
  43. elog "LSI SAS 2304"
  44. elog "LSI SAS 2308"
  45. elog "Dell PERC H200, H700"
  46. elog "IBM System x3200 M2 (4367, 4368)"
  47. elog "IBM System x3200 M3 (7327, 7328)"
  48. elog "IBM System x3250 M2 (4190, 4191, 4194)"
  49. elog "IBM System x3250 M3 (4251, 4252, 4261)"
  50. elog "IBM System x3350 (4192, 4193)"
  51. elog "IBM System x3400 (7973, 7974, 7975, 7976)"
  52. elog "IBM System x3400 M2 (7836, 7837)"
  53. elog "IBM System x3455 (7940, 7941)"
  54. elog "IBM System x3500 (7977)"
  55. elog "IBM System x3500 M2 (7839)"
  56. elog "IBM System x3550 (7978, 1913)"
  57. elog "IBM System x3550 M2 (7946, 4198)"
  58. elog "IBM System x3650 (7979, 1914)"
  59. elog "IBM System x3650 M2 (7947, 4199)"
  60. elog "IBM System x3650 NAS (7979)"
  61. elog "IBM System x3655 (7985, 7943)"
  62. elog "IBM System x3755 (8877, 7163)"
  63. elog "IBM System x3850 M2 (7141, 7144, 7233, 7234)"
  64. elog "IBM System x3850 X5 (7145, 7146)"
  65. elog "IBM System x3950 M2 (7141, 7233, 7234)"
  66. elog "IBM System x3950 X5 (7145)"
  67. }
  68. src_unpack() {
  69. unpack ${DISTFILE_BIN}
  70. }
  71. src_install() {
  72. exeinto /opt/lsi/
  73. use amd64 || use x86 && doexe sas2ircu_linux_x86_rel/sas2ircu
  74. use ppc64 && doexe sas2ircu_linux_x86_rel/sas2ircu
  75. use amd64-fbsd && doexe sas2ircu_freebsd_amd64_rel/sas2ircu
  76. use x86-fbsd && doexe sas2ircu_freebsd_i386_rel/sas2ircu
  77. use x64-solaris || use x86-solaris && doexe sas2ircu_solaris_x86_rel/sas2ircu
  78. use sparc-solaris && doexe sas2ircu_solaris_sparc_rel/sas2ircu
  79. if use efi; then
  80. exeinto /boot/efi/
  81. doexe sas2ircu_efi_ebc_rel/sas2ircu.efi
  82. fi
  83. dodoc Readme_Release_Notes_SAS2IRCU_Phase_17.00.00.00.txt
  84. dodoc SAS2IRCU_Phase${PV}.0-${PV}.00.00.00.pdf
  85. use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
  86. }