keepalived-1.2.15.ebuild 1.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools base
  5. DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
  6. HOMEPAGE="http://www.keepalived.org/"
  7. SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 ~s390 sparc x86"
  11. IUSE="debug ipv6 snmp"
  12. RDEPEND="dev-libs/popt
  13. sys-apps/iproute2
  14. dev-libs/libnl
  15. dev-libs/openssl
  16. snmp? ( net-analyzer/net-snmp )"
  17. DEPEND="${RDEPEND}
  18. >=sys-kernel/linux-headers-2.6.30"
  19. PATCHES=(
  20. "${FILESDIR}"/${PN}-1.2.2-libipvs-fix-backup-daemon.patch
  21. )
  22. DOCS=( README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO
  23. doc/keepalived.conf.SYNOPSIS doc/NOTE_vrrp_vmac.txt )
  24. src_prepare() {
  25. base_src_prepare
  26. eautoreconf
  27. }
  28. src_configure() {
  29. STRIP=/bin/true \
  30. econf \
  31. --with-kernel-dir=/usr \
  32. --enable-vrrp \
  33. $(use_enable debug) \
  34. $(use_enable snmp)
  35. }
  36. src_install() {
  37. default
  38. newinitd "${FILESDIR}"/keepalived.init keepalived
  39. newconfd "${FILESDIR}"/keepalived.confd keepalived
  40. use snmp && dodoc doc/KEEPALIVED-MIB
  41. docinto genhash
  42. dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION || die
  43. # This was badly named by upstream, it's more HOWTO than anything else.
  44. newdoc INSTALL INSTALL+HOWTO
  45. # Security risk to bundle SSL certs
  46. rm -f "${ED}"/etc/keepalived/samples/*.pem
  47. # Clean up sysvinit files
  48. rm -rf "${ED}"/etc/sysconfig "${ED}"/etc/rc.d/
  49. }