libquo-1.2.4-r1.ebuild 802 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. FORTRAN_NEEDED=fortran
  5. FORTRAN_STANDARD=90
  6. inherit autotools-utils fortran-2
  7. if [ "${PV}" = "9999" ]; then
  8. EGIT_REPO_URI="git://github.com/lanl/${PN}.git https://github.com/lanl/${PN}.git"
  9. inherit git-r3
  10. KEYWORDS=""
  11. AUTOTOOLS_AUTORECONF=1
  12. else
  13. SRC_URI="http://lanl.github.io/${PN}/dists/${P}.tar.gz"
  14. KEYWORDS="~amd64"
  15. fi
  16. DESCRIPTION="run-time tuning of process binding policies made easy"
  17. HOMEPAGE="http://lanl.github.io/libquo/"
  18. LICENSE="BSD"
  19. SLOT="0"
  20. IUSE="fortran static-libs"
  21. DEPEND="
  22. virtual/mpi[fortran?]
  23. sys-process/numactl
  24. sys-apps/hwloc[numa,xml]
  25. "
  26. RDEPEND="${DEPEND}"
  27. src_configure() {
  28. autotools-utils_src_configure CC=mpicc FC=$(usex fortran mpif90 false)
  29. }