autoconf-2.13.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit toolchain-autoconf
  5. DESCRIPTION="Used to create autoconfiguration files"
  6. HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="${PV:0:3}"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  11. IUSE="userland_BSD"
  12. DEPEND=">=sys-apps/texinfo-4.3
  13. =sys-devel/m4-1.4*
  14. dev-lang/perl"
  15. RDEPEND="${DEPEND}
  16. >=sys-devel/autoconf-wrapper-13"
  17. PATCHES=(
  18. "${FILESDIR}"/${P}-gentoo.patch
  19. "${FILESDIR}"/${P}-destdir.patch
  20. "${FILESDIR}"/${P}-test-fixes.patch #146592
  21. )
  22. src_configure() {
  23. touch configure # make sure configure is newer than configure.in
  24. # need to include --exec-prefix and --bindir or our
  25. # DESTDIR patch will trigger sandbox hate :(
  26. #
  27. # need to force locale to C to avoid bugs in the old
  28. # configure script breaking the install paths #351982
  29. #
  30. # force to `awk` so that we don't encode another awk that
  31. # happens to currently be installed, but might later be
  32. # uninstalled (like mawk). same for m4.
  33. local prepend=""
  34. use userland_BSD && prepend="g"
  35. ac_cv_path_M4="${prepend}m4" \
  36. ac_cv_prog_AWK="${prepend}awk" \
  37. LC_ALL=C \
  38. econf \
  39. --exec-prefix="${EPREFIX}"/usr \
  40. --bindir="${EPREFIX}"/usr/bin \
  41. --program-suffix="-${PV}"
  42. }