autoconf-2.69.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit eutils
  5. if [[ ${PV} == "9999" ]] ; then
  6. EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
  7. http://git.savannah.gnu.org/r/${PN}.git"
  8. inherit git-2
  9. else
  10. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
  11. ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz"
  12. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
  13. fi
  14. DESCRIPTION="Used to create autoconfiguration files"
  15. HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
  16. LICENSE="GPL-3"
  17. SLOT="2.5"
  18. IUSE="emacs"
  19. DEPEND=">=sys-devel/m4-1.4.16
  20. >=dev-lang/perl-5.6"
  21. RDEPEND="${DEPEND}
  22. >=sys-devel/autoconf-wrapper-13"
  23. PDEPEND="emacs? ( app-emacs/autoconf-mode )"
  24. src_prepare() {
  25. if [[ ${PV} == "9999" ]] ; then
  26. autoreconf -f -i || die
  27. fi
  28. find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
  29. }
  30. src_configure() {
  31. # Disable Emacs in the build system since it is in a separate package.
  32. export EMACS=no
  33. econf --program-suffix="-${PV}" || die
  34. # econf updates config.{sub,guess} which forces the manpages
  35. # to be regenerated which we dont want to do #146621
  36. touch man/*.1
  37. }
  38. src_install() {
  39. emake DESTDIR="${D}" install || die
  40. dodoc AUTHORS BUGS NEWS README TODO THANKS \
  41. ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
  42. local f
  43. for f in "${ED}"/usr/share/info/*.info* ; do
  44. mv "${f}" "${f/.info/-${SLOT}.info}" || die
  45. done
  46. }