autoconf-9999.ebuild 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. if [[ ${PV} == "9999" ]] ; then
  5. EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
  6. http://git.savannah.gnu.org/r/${PN}.git"
  7. # We need all the tags in order to figure out the right version.
  8. # The git-r3 eclass doesn't support that, so have to stick to 2.
  9. inherit git-2
  10. else
  11. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
  12. ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz"
  13. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
  14. fi
  15. inherit toolchain-autoconf
  16. DESCRIPTION="Used to create autoconfiguration files"
  17. HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
  18. LICENSE="GPL-3"
  19. SLOT="${PV}"
  20. IUSE="emacs"
  21. DEPEND=">=sys-devel/m4-1.4.16
  22. >=dev-lang/perl-5.6"
  23. RDEPEND="${DEPEND}
  24. !~sys-devel/${P}:2.5
  25. >=sys-devel/autoconf-wrapper-13"
  26. [[ ${PV} == "9999" ]] && DEPEND+=" >=sys-apps/texinfo-4.3"
  27. PDEPEND="emacs? ( app-emacs/autoconf-mode )"
  28. src_prepare() {
  29. # Avoid the "dirty" suffix in the git version by generating it
  30. # before we run later stages which might modify source files.
  31. local ver=$(./build-aux/git-version-gen .tarball-version)
  32. echo "${ver}" > .tarball-version
  33. autoreconf -f -i || die
  34. toolchain-autoconf_src_prepare
  35. }