autogen-5.18.4.ebuild 988 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils
  5. DESCRIPTION="Program and text file generation"
  6. HOMEPAGE="https://www.gnu.org/software/autogen/"
  7. SRC_URI="mirror://gnu/${PN}/rel${PV}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
  11. IUSE="libopts static-libs"
  12. RDEPEND=">=dev-scheme/guile-1.8
  13. dev-libs/libxml2"
  14. DEPEND="${RDEPEND}"
  15. src_prepare() {
  16. epatch "${FILESDIR}"/${PN}-5.18.4-tmp-log.patch #563352
  17. epatch "${FILESDIR}"/${PN}-5.18.4_fix_format.test_for_dash.patch #576674
  18. }
  19. src_configure() {
  20. # suppress possibly incorrect -R flag
  21. export ag_cv_test_ldflags=
  22. econf $(use_enable static-libs static)
  23. }
  24. src_install() {
  25. default
  26. prune_libtool_files
  27. if ! use libopts ; then
  28. rm "${ED}"/usr/share/autogen/libopts-*.tar.gz || die
  29. fi
  30. }