automake-1.10.3-r1.ebuild 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit eutils
  5. DESCRIPTION="Used to generate Makefile.in from Makefile.am"
  6. HOMEPAGE="https://www.gnu.org/software/automake/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. # Use Gentoo versioning for slotting.
  10. SLOT="${PV:0:4}"
  11. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="dev-lang/perl
  14. >=sys-devel/automake-wrapper-10
  15. >=sys-devel/autoconf-2.69
  16. sys-devel/gnuconfig"
  17. DEPEND="${RDEPEND}
  18. sys-apps/help2man"
  19. src_prepare() {
  20. export WANT_AUTOCONF=2.5
  21. epatch "${FILESDIR}"/${PN}-1.10-perl-5.16.patch #424453
  22. chmod a+rx tests/*.test
  23. }
  24. src_configure() {
  25. econf --docdir="\$(datarootdir)/doc/${PF}"
  26. }
  27. # slot the info pages. do this w/out munging the source so we don't have
  28. # to depend on texinfo to regen things. #464146 (among others)
  29. slot_info_pages() {
  30. pushd "${ED}"/usr/share/info >/dev/null
  31. rm -f dir
  32. # Rewrite all the references to other pages.
  33. # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
  34. # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
  35. local p pages=( *.info ) args=()
  36. for p in "${pages[@]/%.info}" ; do
  37. args+=(
  38. -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
  39. -e "s:(${p}):(${p}-${SLOT}):g"
  40. )
  41. done
  42. sed -i "${args[@]}" * || die
  43. # Rewrite all the file references, and rename them in the process.
  44. local f d
  45. for f in * ; do
  46. d=${f/.info/-${SLOT}.info}
  47. mv "${f}" "${d}" || die
  48. sed -i -e "s:${f}:${d}:g" * || die
  49. done
  50. popd >/dev/null
  51. }
  52. src_install() {
  53. default
  54. slot_info_pages
  55. # SLOT the docs and junk
  56. local x
  57. for x in aclocal automake ; do
  58. help2man "perl -Ilib ${x}" > ${x}-${SLOT}.1
  59. doman ${x}-${SLOT}.1
  60. rm -f "${ED}"/usr/bin/${x}
  61. done
  62. # remove all config.guess and config.sub files replacing them
  63. # w/a symlink to a specific gnuconfig version
  64. for x in guess sub ; do
  65. dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
  66. done
  67. }