automake-1.12.6-r1.ebuild 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="Used to generate Makefile.in from Makefile.am"
  6. HOMEPAGE="https://www.gnu.org/software/automake/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. # Use Gentoo versioning for slotting.
  10. SLOT="${PV:0:4}"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="dev-lang/perl
  14. >=sys-devel/automake-wrapper-10
  15. >=sys-devel/autoconf-2.69
  16. sys-devel/gnuconfig"
  17. DEPEND="${RDEPEND}
  18. sys-apps/help2man"
  19. src_prepare() {
  20. export WANT_AUTOCONF=2.5
  21. epatch "${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket.patch
  22. sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
  23. }
  24. src_configure() {
  25. econf --docdir="\$(datarootdir)/doc/${PF}"
  26. }
  27. # slot the info pages. do this w/out munging the source so we don't have
  28. # to depend on texinfo to regen things. #464146 (among others)
  29. slot_info_pages() {
  30. pushd "${ED}"/usr/share/info >/dev/null
  31. rm -f dir
  32. # Rewrite all the references to other pages.
  33. # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
  34. # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
  35. local p pages=( *.info ) args=()
  36. for p in "${pages[@]/%.info}" ; do
  37. args+=(
  38. -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
  39. -e "s:(${p}):(${p}-${SLOT}):g"
  40. )
  41. done
  42. sed -i "${args[@]}" * || die
  43. # Rewrite all the file references, and rename them in the process.
  44. local f d
  45. for f in * ; do
  46. d=${f/.info/-${SLOT}.info}
  47. mv "${f}" "${d}" || die
  48. sed -i -e "s:${f}:${d}:g" * || die
  49. done
  50. popd >/dev/null
  51. }
  52. src_install() {
  53. default
  54. slot_info_pages
  55. rm "${ED}"/usr/share/aclocal/README || die
  56. rmdir "${ED}"/usr/share/aclocal || die
  57. rm \
  58. "${ED}"/usr/bin/{aclocal,automake} \
  59. "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
  60. # remove all config.guess and config.sub files replacing them
  61. # w/a symlink to a specific gnuconfig version
  62. local x
  63. for x in guess sub ; do
  64. dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
  65. done
  66. }