automake-1.13.4-r1.ebuild 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="Used to generate Makefile.in from Makefile.am"
  6. HOMEPAGE="https://www.gnu.org/software/automake/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. # Use Gentoo versioning for slotting.
  10. SLOT="${PV:0:4}"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  12. IUSE=""
  13. RDEPEND="dev-lang/perl
  14. >=sys-devel/automake-wrapper-10
  15. >=sys-devel/autoconf-2.69
  16. sys-devel/gnuconfig"
  17. DEPEND="${RDEPEND}
  18. sys-apps/help2man"
  19. src_prepare() {
  20. export WANT_AUTOCONF=2.5
  21. epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
  22. epatch "${FILESDIR}"/${PN}-1.13-perl-escape-curly-bracket.patch
  23. sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
  24. }
  25. src_configure() {
  26. econf --docdir="\$(datarootdir)/doc/${PF}"
  27. }
  28. src_test() {
  29. emake check
  30. }
  31. # slot the info pages. do this w/out munging the source so we don't have
  32. # to depend on texinfo to regen things. #464146 (among others)
  33. slot_info_pages() {
  34. pushd "${ED}"/usr/share/info >/dev/null
  35. rm -f dir
  36. # Rewrite all the references to other pages.
  37. # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
  38. # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
  39. local p pages=( *.info ) args=()
  40. for p in "${pages[@]/%.info}" ; do
  41. args+=(
  42. -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
  43. -e "s:(${p}):(${p}-${SLOT}):g"
  44. )
  45. done
  46. sed -i "${args[@]}" * || die
  47. # Rewrite all the file references, and rename them in the process.
  48. local f d
  49. for f in * ; do
  50. d=${f/.info/-${SLOT}.info}
  51. mv "${f}" "${d}" || die
  52. sed -i -e "s:${f}:${d}:g" * || die
  53. done
  54. popd >/dev/null
  55. }
  56. src_install() {
  57. default
  58. slot_info_pages
  59. rm "${ED}"/usr/share/aclocal/README || die
  60. rmdir "${ED}"/usr/share/aclocal || die
  61. rm \
  62. "${ED}"/usr/bin/{aclocal,automake} \
  63. "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
  64. # remove all config.guess and config.sub files replacing them
  65. # w/a symlink to a specific gnuconfig version
  66. local x
  67. for x in guess sub ; do
  68. dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
  69. done
  70. }