clang-3.5.2-r100.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib-build
  5. DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
  6. HOMEPAGE="http://clang.llvm.org/"
  7. SRC_URI=""
  8. LICENSE="UoI-NCSA"
  9. SLOT="0/3.5"
  10. KEYWORDS="~amd64 ~arm ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE="debug multitarget python +static-analyzer"
  12. RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
  13. # Please keep this package around since it's quite likely that we'll
  14. # return to separate LLVM & clang ebuilds when the cmake build system
  15. # is complete.
  16. pkg_postinst() {
  17. if has_version ">=dev-util/ccache-3.1.9-r2" ; then
  18. #add ccache links as clang might get installed after ccache
  19. "${EROOT}"/usr/bin/ccache-config --install-links
  20. fi
  21. }
  22. pkg_postrm() {
  23. if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
  24. # --remove-links would remove all links, --install-links updates them
  25. "${EROOT}"/usr/bin/ccache-config --install-links
  26. fi
  27. }