gcc-3.3.6-r1.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PATCH_VER="1.9"
  5. UCLIBC_VER="1.0"
  6. HTB_VER="1.00-r2"
  7. inherit eutils toolchain
  8. # ia64 - broken static handling; USE=static emerge busybox
  9. KEYWORDS="~amd64 ~x86"
  10. # NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
  11. # .eh_frame ld optimisation and symbol visibility support, but it hasnt been
  12. # well tested in gentoo on any arch other than amd64!!
  13. RDEPEND=">=sys-devel/binutils-2.14.90.0.6-r1"
  14. DEPEND="${RDEPEND}
  15. amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
  16. src_prepare() {
  17. toolchain_src_prepare
  18. if [[ -n ${UCLIBC_VER} ]] && [[ ${CTARGET} == *-uclibc* ]] ; then
  19. mv "${S}"/gcc-3.3.2/libstdc++-v3/config/os/uclibc "${S}"/libstdc++-v3/config/os/ || die
  20. mv "${S}"/gcc-3.3.2/libstdc++-v3/config/locale/uclibc "${S}"/libstdc++-v3/config/locale/ || die
  21. fi
  22. # Anything useful and objc will require libffi. Seriously. Lets just force
  23. # libffi to install with USE="objc", even though it normally only installs
  24. # if you attempt to build gcj.
  25. if use objc && ! use gcj ; then
  26. epatch "${FILESDIR}"/3.3.4/libffi-without-libgcj.patch
  27. #epatch "${FILESDIR}"/3.4.3/libffi-nogcj-lib-path-fix.patch
  28. fi
  29. }