123456789101112131415161718192021222324252627282930 |
- # Copyright 1999-2016 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- PATCH_VER="1.3"
- UCLIBC_VER="1.0"
- inherit eutils toolchain
- KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
- RDEPEND=""
- DEPEND="${RDEPEND}
- elibc_glibc? ( >=sys-libs/glibc-2.8 )
- ppc? ( >=${CATEGORY}/binutils-2.17 )
- ppc64? ( >=${CATEGORY}/binutils-2.17 )
- >=${CATEGORY}/binutils-2.15.94"
- if [[ ${CATEGORY} != cross-* ]] ; then
- PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
- fi
- src_prepare() {
- toolchain_src_prepare
- use vanilla && return 0
- sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
- }
|