gcc-4.6.4.ebuild 768 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PATCH_VER="1.3"
  5. UCLIBC_VER="1.0"
  6. inherit eutils toolchain
  7. KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
  8. RDEPEND=""
  9. DEPEND="${RDEPEND}
  10. elibc_glibc? ( >=sys-libs/glibc-2.8 )
  11. >=${CATEGORY}/binutils-2.18"
  12. if [[ ${CATEGORY} != cross-* ]] ; then
  13. PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
  14. fi
  15. src_prepare() {
  16. if has_version '<sys-libs/glibc-2.12' ; then
  17. ewarn "Your host glibc is too old; disabling automatic fortify."
  18. ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
  19. EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
  20. fi
  21. toolchain_src_prepare
  22. }