gdb-apple-768-r1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit eutils flag-o-matic
  5. DESCRIPTION="Apple branch of the GNU Debugger, 10.5"
  6. HOMEPAGE="https://sourceware.org/gdb/"
  7. SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.tar.gz"
  8. LICENSE="APSL-2 GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~ppc-macos ~x86-macos"
  11. IUSE="nls"
  12. RDEPEND=">=sys-libs/ncurses-5.2-r2
  13. =dev-db/sqlite-3*"
  14. DEPEND="${RDEPEND}
  15. nls? ( sys-devel/gettext )"
  16. S=${WORKDIR}/gdb-${PV}/src
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-texinfo.patch
  19. epatch "${FILESDIR}"/${P}-darwin-arch.patch
  20. # for FSF gcc / gcc-apple:42
  21. sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
  22. eapply_user
  23. }
  24. src_configure() {
  25. replace-flags -O? -O2
  26. econf \
  27. --disable-werror \
  28. $(use_enable nls) \
  29. || die
  30. }
  31. src_install() {
  32. emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
  33. rm -r "${D}"/nukeme || die
  34. rm -Rf "${ED}"/usr/${CHOST} || die
  35. mv "${ED}"/usr/bin/gdb "${ED}"/
  36. rm -f "${ED}"/usr/bin/*
  37. mv "${ED}"/gdb "${ED}"/usr/bin/
  38. }