make-3.81-r2.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit flag-o-matic eutils
  4. DESCRIPTION="Standard tool to compile source trees"
  5. HOMEPAGE="https://www.gnu.org/software/make/make.html"
  6. SRC_URI="mirror://gnu//make/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
  10. IUSE="nls static"
  11. DEPEND="nls? ( sys-devel/gettext )"
  12. RDEPEND="nls? ( virtual/libintl )"
  13. src_unpack() {
  14. unpack ${A}
  15. cd "${S}"
  16. epatch "${FILESDIR}"/${P}-tests-lang.patch
  17. epatch "${FILESDIR}"/${P}-long-cmdline.patch #301116
  18. epatch "${FILESDIR}"/${P}-tests-recursion.patch #329153
  19. epatch "${FILESDIR}"/${P}-jobserver.patch #193258
  20. }
  21. src_compile() {
  22. use static && append-ldflags -static
  23. econf \
  24. $(use_enable nls) \
  25. --program-prefix=g \
  26. || die
  27. emake || die
  28. }
  29. src_install() {
  30. emake DESTDIR="${D}" install || die "make install failed"
  31. dodoc AUTHORS ChangeLog NEWS README*
  32. if [[ ${USERLAND} == "GNU" ]] ; then
  33. # we install everywhere as 'gmake' but on GNU systems,
  34. # symlink 'make' to 'gmake'
  35. dosym gmake /usr/bin/make
  36. dosym gmake.1 /usr/share/man/man1/make.1
  37. fi
  38. }