parity-1.2.5.ebuild 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="An Interix to native Win32 Cross-Compiler Tool (requires Visual Studio)"
  5. HOMEPAGE="http://www.sourceforge.net/projects/parity/"
  6. if [[ ${PV} == 9999 ]]; then
  7. inherit subversion
  8. ESVN_REPO_URI="https://svn.code.sf.net/p/parity/code/trunk"
  9. ESVN_BOOTSTRAP="confix --bootstrap"
  10. ESVN_PROJECT="${PN}"
  11. KEYWORDS=""
  12. DEPEND="dev-util/confix"
  13. else
  14. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  15. KEYWORDS="~x86-winnt"
  16. fi
  17. LICENSE="LGPL-3"
  18. SLOT="0"
  19. IUSE=""
  20. pkg_setup() {
  21. if [ -z "${MSSDK}" ]; then
  22. einfo "NOTE: When using Visual Studio 2008, the Platform SDK is no longer"
  23. einfo "installed alongside with the other components, but has it's own"
  24. einfo "root directory, most likely something like this:"
  25. einfo ""
  26. einfo " C:\\Program Files\\Microsoft SDKs\\Windows\\v6.0A"
  27. einfo ""
  28. einfo "To make parity find it's paths correctly, please set MSSDK to the"
  29. einfo "value correspoding to the above example for your system."
  30. fi
  31. }
  32. src_install() {
  33. emake DESTDIR="${D}" install || die "emake install failed"
  34. # create i586-pc-winnt*-g[++|cc|..] links..
  35. local exeext=
  36. [[ -f ${ED}/usr/bin/parity.gnu.gcc.exe ]] && exeext=.exe
  37. # create cross compiler syms
  38. dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-gcc
  39. dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-c++
  40. dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-g++
  41. dosym /usr/bin/parity.gnu.ld${exeext} /usr/bin/i586-pc-winnt$(uname -r)-ld
  42. # we don't need the header files installed by parity... private
  43. # header files are supported with a patch from 2.1.0-r1 onwards,
  44. # so they won't be there anymore, but -f does the job in any case.
  45. rm -f "${ED}"/usr/include/*.h
  46. }