libnes-1.1.4.ebuild 559 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. OFED_VER="3.12"
  5. OFED_RC="1"
  6. OFED_RC_VER="1"
  7. OFED_SUFFIX="0"
  8. inherit openib
  9. DESCRIPTION="NetEffect RNIC Userspace Library"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux"
  11. IUSE="static-libs"
  12. DEPEND="sys-fabric/libibverbs:${SLOT}"
  13. RDEPEND="${DEPEND}
  14. !sys-fabric/openib-userspace"
  15. block_other_ofed_versions
  16. src_configure() {
  17. econf $(use_enable static-libs static)
  18. }
  19. src_install() {
  20. default
  21. use static-libs || rm -f "${D}"usr/$(get_libdir)/${PN}.la
  22. }