iwl8000-ucode-16.242414.0.ebuild 935 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit linux-info
  5. MY_P="iwlwifi-${P#iwl}"
  6. DESCRIPTION="Firmware for Intel (R) Wireless 8260 and 4165"
  7. HOMEPAGE="https://wireless.kernel.org/en/users/Drivers/iwlwifi"
  8. SRC_URI="https://wireless.wiki.kernel.org/_media/en/users/drivers/${MY_P}.tgz"
  9. LICENSE="ipw3945"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. DEPEND=""
  13. RDEPEND="
  14. !sys-kernel/linux-firmware[-savedconfig]
  15. "
  16. CONFIG_CHECK="~IWLMVM"
  17. ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
  18. S="${WORKDIR}/${MY_P}"
  19. pkg_pretend() {
  20. if kernel_is lt 4 3 0; then
  21. eerror "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
  22. eerror "This microcode image requires a kernel >= 4.3.0."
  23. fi
  24. }
  25. src_install() {
  26. insinto /lib/firmware
  27. doins iwlwifi-8000C-16.ucode
  28. dodoc README*
  29. }