arm-fdisk-3.0.6-r1.ebuild 1001 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DEB_VER=6.2
  5. DESCRIPTION="edit disk partitions on Acorn machines"
  6. HOMEPAGE="http://www.arm.linux.org.uk/"
  7. SRC_URI="ftp://ftp.arm.linux.org.uk/pub/armlinux/source/other/${P}.tar.gz
  8. mirror://debian/pool/main/a/acorn-fdisk/acorn-fdisk_${PV}-${DEB_VER}.diff.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc s390 sh sparc x86"
  12. IUSE=""
  13. DEPEND=""
  14. src_unpack() {
  15. unpack ${A}
  16. cd "${S}"
  17. epatch "${WORKDIR}"/acorn-fdisk_${PV}-${DEB_VER}.diff
  18. find "${S}" -name Makefile -print0 | xargs -0 \
  19. sed -i \
  20. -e "s:-O2 -Wall\( -g\)\?::" \
  21. -e "/^CFLAGS/s:=:+=:" \
  22. -e "/^LDFLAGS/s:=:+=:" \
  23. -e '/^STRIP/s:strip:true:'
  24. }
  25. src_compile() {
  26. emake \
  27. CC="$(tc-getCC)" \
  28. AR="$(tc-getAR)" || die
  29. }
  30. src_install() {
  31. into /
  32. newsbin fdisk ${PN} || die "sbin failed"
  33. dosym ${PN} /sbin/acorn-fdisk
  34. dodoc ChangeLog README debian/changelog
  35. }