aufs-util-3.19_p20150420.ebuild 1005 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic linux-info multilib toolchain-funcs
  5. DESCRIPTION="Utilities are always necessary for aufs"
  6. HOMEPAGE="http://aufs.sourceforge.net/"
  7. SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
  8. # git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs3.14 -o ${P}.tar
  9. # xz -ve9 *.tar
  10. SLOT="0"
  11. LICENSE="GPL-2"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RDEPEND="
  15. !sys-fs/aufs2
  16. !<sys-fs/aufs3-3_p20130318"
  17. DEPEND="${RDEPEND}
  18. ~sys-fs/aufs-headers-${PV}"
  19. src_prepare() {
  20. sed \
  21. -e "/LDFLAGS += -static -s/d" \
  22. -e "/CFLAGS/s:-O::g" \
  23. -i Makefile || die
  24. sed \
  25. -e '/LDFLAGS/s: -s::g' \
  26. -e "s:m 644 -s:m 644:g" \
  27. -e "s:/usr/lib:/usr/$(get_libdir):g" \
  28. -i libau/Makefile || die
  29. sed \
  30. -e '/LDFLAGS/s: -s::g' \
  31. -e '/LDLIBS/s:-lrt::g' \
  32. -e '/LDLIBS/s:$: -lrt:g' \
  33. -i fhsm/Makefile || die
  34. tc-export CC AR
  35. export HOSTCC=$(tc-getCC)
  36. }