aufs-util-4.0_p20150420.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils flag-o-matic linux-info multilib toolchain-funcs
  5. DESCRIPTION="Utilities are always necessary for aufs"
  6. HOMEPAGE="http://aufs.sourceforge.net/"
  7. SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
  8. # git archive -v --prefix=${P}/ --remote=git://git.code.sf.net/p/aufs/aufs-util aufs4.0 -o ${P}.tar
  9. # xz -ve9 *.tar
  10. SLOT="0"
  11. LICENSE="GPL-2"
  12. KEYWORDS="amd64 x86"
  13. IUSE=""
  14. RDEPEND="
  15. !sys-fs/aufs2
  16. !<sys-fs/aufs3-3_p20130318"
  17. DEPEND="${RDEPEND}
  18. ~sys-fs/aufs-headers-${PV}"
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${P}-version.patch
  21. sed \
  22. -e "/LDFLAGS += -static -s/d" \
  23. -e "/CFLAGS/s:-O::g" \
  24. -i Makefile || die
  25. sed \
  26. -e '/LDFLAGS/s: -s::g' \
  27. -e "s:m 644 -s:m 644:g" \
  28. -e "s:/usr/lib:/usr/$(get_libdir):g" \
  29. -i libau/Makefile || die
  30. sed \
  31. -e '/LDFLAGS/s: -s::g' \
  32. -e '/LDLIBS/s:-lrt::g' \
  33. -e '/LDLIBS/s:$: -lrt:g' \
  34. -i fhsm/Makefile || die
  35. tc-export CC AR
  36. export HOSTCC=$(tc-getCC)
  37. }